Videonizer will not load.

All about the program
Post Reply
Posts: 15
Joined: 05 Jun 2014, 15:23

13 Aug 2019, 21:49

I cant get videonizer to load, its been working fine for years.
Today I load it and it appears in the task manager for about 2 seconds then disappears, no splash screen for videonizer appears.
Ive tried re-installing, "deleting HKEY_CURRENT_USER\Software\SUU Design\Videonizer", deleting the database i use, installing it in a different directory, installing on a different drive, running in compatibility mode, admin on and off, adding an exclusion to windows defender.
Last windows 10 update was 25th july and it worked after that.

It had done the same thing a week ago but i fixed it then by moving the database so videonizer would ask me to load a database, i selected the moved database and it worked fine again. But now nothing will fix it.

I have also tried safe mode, videonizer loads and asks for a database, i press ok then cancel, videonizer then asks for a new database, so i select a new directory and name and press ok, videonizer then closes and there is no new database in the directory i chose.

Ok im back to normal mode now and the videonizer i have installed in C:\Other Programs\Videonizer will now give me a splash screen then close.
The videonizer i installed in D:\Program Files\Videonizer loads a new database called newVideonizerDB.db3 in the same directory.
I can then load my old database and it works fine, but the videonizer in C: still wont load.

Any ideas?
User avatar
Site Admin
Posts: 1089
Joined: 03 Jun 2014, 22:14

13 Aug 2019, 23:19


1) Did you check Windows event viewer? Probably, an info event is logged there after startup.
2) What Videonizer version are you using? What is the size (in bytes) of the executable?
Posts: 15
Joined: 05 Jun 2014, 15:23

14 Aug 2019, 09:02

Heres the errors from event viewer.

First one is a .NET Runtime

Code: Select all

Application: Videonizer.exe
Framework Version: v4.0.30319
Description: The process was terminated due to an unhandled exception.
Exception Info: System.ArgumentException
   at System.Data.Common.DbProviderFactories.GetFactory(System.String)
   at ‌‮‎‫​‎‬‎‏‫‌‭‪​‍‬‮‫‭‬‮‏‍‮‭‮‌​‍‮.‫‬‌‫‭‮‍‎‫‎‮‏‭‏‏‪‬‬‎‮​‬‮‮(System.String)
   at ‌‮‎‫​‎‬‎‏‫‌‭‪​‍‬‮‫‭‬‮‏‍‮‭‮‌​‍‮..cctor()

Exception Info: System.TypeInitializationException
   at ‌‮‎‫​‎‬‎‏‫‌‭‪​‍‬‮‫‭‬‮‏‍‮‭‮‌​‍‮.‍‎​‍‬‏‫‬‬‍​‪‍‌‎‫‌‮‮‭‭‎‏‮‮‎‏‮()
   at '/2}\*?Z-1dZW Mq'hcqOK\*J>$.‪‫‮‏​‌‍‌‎‭‌‌‭‭‭​‬‭‍‏‬‏‮‫‮()
   at '/2}\*?Z-1dZW Mq'hcqOK\*J>$..ctor()
   at ​‫‎​‏‮‎‏‏‮‭‌‮‭‌‏‮‫‮‮.​‌‏‪‭‍‪‌‮​‪‌​​‏‪‎‫‎​‪‬‮‪‪‏‮‬‮(System.String[])
2nd is a Application Error

Code: Select all

Faulting application name: Videonizer.exe, version:, time stamp: 0x5d34120f
Faulting module name: KERNELBASE.dll, version: 10.0.18362.239, time stamp: 0xe665f337
Exception code: 0xe0434352
Fault offset: 0x00113442
Faulting process ID: 0x730
Faulting application start time: 0x01d552083f0c2e74
Faulting application path: C:\Other Programs\Videonizer\Videonizer.exe
Faulting module path: C:\WINDOWS\System32\KERNELBASE.dll
Report ID: af78edca-62dc-4995-8e46-3236ef2acf9d
Faulting package full name: 
Faulting package-relative application ID:
3rd is a Windows Error Reporting

Code: Select all

Fault bucket , type 0
Event Name: CLR20r3
Response: Not available
Cab Id: 0

Problem signature:
P1: Videonizer.exe
P3: 5d34120f
P4: System.Data
P5: 4.8.3752.0
P6: 5c7a243e
P7: 305f
P8: 2b
P9: System.ArgumentException

Attached files:

These files may be available here:

Analysis symbol: 
Rechecking for solution: 0
Report Id: af78edca-62dc-4995-8e46-3236ef2acf9d
Report Status: 100
Hashed bucket: 
Cab Guid: 0
and ive attached the crash report.
(2.6 KiB) Downloaded 326 times
User avatar
Site Admin
Posts: 1089
Joined: 03 Jun 2014, 22:14

14 Aug 2019, 13:07

You have the same error like in the nearby thread:

My current advice is:
Please try to use the following config file (Videonizer.exe.config) instead of original one:

Code: Select all

<?xml version="1.0" encoding="utf-8"?>
        <sectionGroup name="userSettings" type="System.Configuration.UserSettingsGroup, System, Version=, Culture=neutral, PublicKeyToken=b77a5c561934e089">
            <section name="PornOrganizer.Properties.Settings" type="System.Configuration.ClientSettingsSection, System, Version=, Culture=neutral, PublicKeyToken=b77a5c561934e089" allowExeDefinition="MachineToLocalUser" requirePermission="false"/>

      <remove invariant="System.Data.SQLite"/>
      <add name="SQLite Data Provider" invariant="System.Data.SQLite" description=".Net Framework Data Provider for SQLite" type="System.Data.SQLite.SQLiteFactory, System.Data.SQLite,
                 Version=, Culture=neutral,

  <startup useLegacyV2RuntimeActivationPolicy="true">
    <supportedRuntime version="v4.0" sku=".NETFramework,Version=v4.0,Profile=Client"/>

Posts: 15
Joined: 05 Jun 2014, 15:23

15 Aug 2019, 11:45

After getting videonizer to work on D: its now working on C: again.

But i'll give the new config a go if it stops working again, thanks.
Posts: 15
Joined: 05 Jun 2014, 15:23

15 Aug 2019, 19:06

Videonizer loaded fine this morning, but in the afternoon its not working.

I tried the new config and it does not fix the problem.
Posts: 15
Joined: 05 Jun 2014, 15:23

16 Aug 2019, 11:07

Ok so now its the following morning and its back to working again, i didn't reboot or turn my computer off at night or change anything.
Post Reply