Page 1 of 1

FAQ

PostPosted: 05 Jun 2014, 14:47
by admin
Q. What software is required to run Twins?
A. Twins requires Microsoft Windows and Microsoft .NET Framework 4.0+ to be installed.

Q. Is it free of charge?
A. Yes, it is.