Page 1 of 4

.NET Framework woes. (now Trusteer Rapport)

PostPosted: 01 Aug 2017, 20:45
by Doddie
I suspect this is one of those occasions where this might be specific to my setup, but I'm asking the question because i seem to be going around in circles. (FWIW, Silver subscriber).

For months (spanning many releases of VTM) I've suffered a slow down when thumbnails are made, the best way to describe it is that even though VTM works, the thumbnail making process is faster using the system codecs in engine 1 or 2... than the ultimate or crystal method using the embedded codecs.

Whilst I've long suspected this might be related to an issue with .NET Framework I've avoided it because it's a nightmare trying to remove .NET Framework and do clean re-installs... that's if you can even work out which version of .NET Framework is corrupted... and what's causing the corruption!

Anyways, last night i'd had enough of messing about with codecs (to rule them out) etc and decided to try a repair install on my Windows 7 Pro 64 bit version...

After the repair install finished i was met with the usual dozens upon dozens of updates to complete... but their were two notable updates that refused to complete despite repeated attempts and both of them were .NET Framework related.. KB's 2901983 & 3102433

I thought i'd cracked it when i uninstalled and re-installed the .NET Framework 4 Client Profile for Windows 7 x64 as the speeds i'd seen before with VTM returned, but something isn't right because I've just gone through my other installed programmes to make sure they still work... i.e. that the required "NET Framework" for those programmes is installed...

And somehow something has broken again because I'm right back where i started, VTM is once again slower with the embedded codecs than with the system ones.

If anyone has any idea what's going on or how i can resolve this it would be much appreciated.

Re: .NET Framework woes.

PostPosted: 02 Aug 2017, 20:58
by Doddie
I forgot to mention that i run Windows 7 Professional 64 bit.

In any case i give up, despite hours or removing and re-installing various versions of .NET Framework and re-installing VTM i simply cannot get VTM working as i know it should (the VTM YouTube video is exactly how works, when it works)... i can't even reproduce the normal working condition that i saw yesterday... doing another repair install of Windows 7 is off the cards, i simply don't have the time or the patience... in my mind I've proved that something isn't right with VTM, or it's implementation of .NET 4

This MSDN blog should, with the aid of the cleanup tool allow me to get my .NET Framework working again with VTM... but it doesn't, not even downloading the .NET 4 version that VTM insists i need when all other versions of .NET 4 are removed will get it working correctly, it's incredibly frustrating that it doesn't. ... ers-guide/

I'm almost certain i don't have any other software issues with any other programmes that require .NET Framework other that VTM (any doubts are born by my experience with VTM since the introduction of the prerequisite for .NET 4 a while back, that is, I'm pretty sure that's when the issue began?).

If it helps, my security software is:

Malwarebytes Premium 3.1.2 (doubtful as an issue as this problem existed before i upgraded to Premium and i disabled it when trying to resolve this issue).
Microsoft Security Essentials.
Microsoft Firewall.
Spywareblaster 5.5
Adguard 6.2, an adblocker so not strictly security software, it's a beta version but is also relies on .NET Framework 4.0 and has no issues. (Again, tested with it disabled to rule it out as an issue.)

Anyway, as I'm not seeing any response or corroboration that others see the same results i guess i'll just have to hope that one day my issue is inadvertently resolved ;)

Re: .NET Framework woes.

PostPosted: 02 Aug 2017, 21:02
by admin
Hello Doddie.

I have never heard about such issues.
I will try to find something helpful and will let you know in case of success.

Re: .NET Framework woes.

PostPosted: 02 Aug 2017, 21:05
by admin
Have you tried to use a virtual machine?
It is most likely that a program from your security software list slows down VTM for some reason.
My advice is to try to run VTM in a safe environment without that software.
Is it possible?

Re: .NET Framework woes.

PostPosted: 02 Aug 2017, 21:18
by Doddie
I've never used or been interested in a 'virtual machine', so no.

I'd be surprised if my security software list was the cause but I'm open to anything.

When you ask about running VTM in a safe environment, how would i do that?

Re: .NET Framework woes.

PostPosted: 02 Aug 2017, 21:32
by admin
I mean - could you just try to turn security soft off one by one?
I do not want you to harm your data or PC or something else, that is why I am asking you to perform a test without a risk.
Virtual machine could be an option in that case.

Re: .NET Framework woes.

PostPosted: 02 Aug 2017, 21:56
by Doddie
I've tried that, clean booting was one of the first things i tried yesterday when the problem resurfaced... i still have no idea why it broke because i thought i'd got it sorted when VTM started to fly again... but something keeps breaking and no amount of reinstalling/removing .NET or VTM will get it working as it should.

Clearly something isn't right because a repair install of Win7 at least got VTM working on my PC again as it should, albeit briefly. But what's breaking it and stopping it from working as intended has me baffled... i don't recall the full events of what happened last night (I'm sure you appreciate how many updates MS throw at users for .NET versions) but something somewhere along the line is breaking something.

If you really want me to go down the Virtual Machine route I'm happy to try that, just point me in the direction of a trusted VM that won't cost me and i'll get back to you in the morning.... it's dinner time lol ;)

Re: .NET Framework woes.

PostPosted: 03 Aug 2017, 17:45
by Doddie
I just tried installing Windows Virtual PC (KB958559) but when i try to install Windows 7 on the virtual drive it stops after loading files with an error message telling me my CPU isn't compatible with 64bit operating systems, interesting, as I'm running the 64bit version of Win7 Pro and the processor is an AMD FX8320E that most definitely supports 64bit.

Anyway, i tried installing and uninstalling KB958559 3 times in case i got something wrong but each time i got the same error.

I guess that rules out VM's?

Regardless, don't worry about breaking something, something is already broken and if trying to find out what the cause is results in a format and fresh install then if that's what it takes, I'm good with that, i have all my data etc backed up elsewhere anyway.

Re: .NET Framework woes.

PostPosted: 03 Aug 2017, 18:25
by admin
My idea was to use a Virtual Machine.

Probably, VMware Workstation Pro, probably Oracle VM VirtualBox.
You can install a fresh Windows 7 there + .NET4 Client Profile (Client profile is enough to run VTM).
After installing a fresh Windows on a virtual machine you can create a snapshot, and easy roll back to it when needed.
That is very handy for experiments.

Also I would like to advice you to check Windows event viewer for possible Windows or software errors.
Please have a look: ... s-7-a.html

Re: .NET Framework woes.

PostPosted: 03 Aug 2017, 20:05
by Doddie
admin wrote:Also I would like to advice you to check Windows event viewer for possible Windows or software errors.
Please have a look: ... s-7-a.html

I'll have a look at those VM's later (probably tomorrow now).

Your suggestion for checking out Event Viewer was intriguing, i'd looked there before for errors but i hadn't gone back in time... i'd always assumed that whatever the issue was Event Viewer would throw up a flag every time VTM was run but it appears it doesn't... i rebooted tonight noting the time as 20:12, waited for the system to stabilise, opened VTM and ran it with a handful of files... opened Event Viewer and there were no issues other than 'information' after that time.

Now, the intriguing part... I've managed to narrow down all the .NET Runtime "errors" and they go right back to just before Christmas which is about the time i first started to have this issue... i remember that because it's a busy time of year and it drove me nuts! LOL

There are 55 of them, not all are related to VTM as some are related to when I've removed .NET 4 to try to find a resolution and the other software has flagged up an error as a result. But the clear trend is that VTM has and continues to have issues where other software reliant on .NET 4.x doesn't.

If you'd like to see those log files i'll be more than happy to upload them, but because Event Viewer gives various options for saving the files i'd appreciate if you could let me know in what format you'd like them.